Debian 9 (Stretch) 上使用 SSR 客户端

本文介绍如何在 Debian 系统上使用 SSR 客户端。服务端部署教程见这里

注:以下的所有命令,都是针对 Debian 9 Stretch,并在普通用户下执行的。

由于众所周知的原因,原版 SSR 的项目清空。本文使用由 Akkariiin 维护的 shadowsocksrr

准备

安装必要的软件:

sudo apt update && sudo apt install git vim -y

如该用户不是 sudo 组,可以在 root 用户下安装:

apt update && apt install git vim -y

安装

mkdir -p ~/Softwares/Proxy
cd ~/Softwares/Proxy
git clone --branch akkariiin/master https://github.com/shadowsocksrr/shadowsocksr.git
cd shadowsocksr
bash initcfg.sh

Read More

Debian 9 (Stretch) 上部署 SSR 服务端

本文介绍如何在 Debian 9 系统上部署 Shadowsocks R 服务端。

注:以下的所有命令,都是针对 Debian 9 Stretch,并在 root 用户下执行的。

由于众所周知的原因,原版 SSR 的项目清空。本文使用由 Akkariiin 维护的 shadowsocksrr

准备

安装必要的软件:

apt update && apt install git vim -y

安装

cd /root
git clone --branch akkariiin/master https://github.com/shadowsocksrr/shadowsocksr.git
cd shadowsocksr
bash initcfg.sh

Read More

Debian 9 (Stretch) 上使用 shadowsocks-libev 客户端并开启混淆

本文介绍如何在 Debian 系统上使用 ss-libev 客户端。服务端部署教程见这里

注:使用 simple-obfs 混淆时,请确认服务端同样开启了混淆功能。以下的所有命令,都是针对 Debian 9 Stretch,并在 root 用户下执行的。

安装

添加 stretch-backports

sh -c 'printf "deb http://deb.debian.org/debian stretch-backports main" > /etc/apt/sources.list.d/stretch-backports.list'

apt update

安装 shadowsocks-libevsimple-obfs

apt -t stretch-backports install shadowsocks-libev simple-obfs -y

Read More

打造 Android TV Box 的应用体验

之前某宝买了一个 MXR Pro 三无安卓电视盒子。内置了谷歌商店,不过谷歌商店的版本是手机版的,使用遥控器操作十分不便,需要鼠标键盘才可以。而从商店里安装的应用也不是 TV 版的,无论从美观还是实用角度,都不是很适合。本文简要介绍如何让三无盒子拥有与经过认证的 Android TV box 一致的体验。

声明:仅供参考,风险自负。

准备

登录 Google 商店,安装 ES 文件管理器。设备已 root 。

下载 tv_core_hardware.xmltv_features.xml 两个 xml 文件。

在 Apkmirror 网站下载 Google Play Store (Android TV)Google Play services (Android TV) 两个应用的 apk 文件。

Read More

安装 hexo-all-minifier 插件遇到的一些问题

有空更新了一下 nodejs 的版本,又更新了 hexo,尝试了一下 hexo-all-minifier 插件。不过最后还是换回了古老的 hexo-console-optimize。记录一下安装前者遇到的问题。

操作系统: Debian

npm install hexo-all-minifier --save

报错:

✖ Error: pngquant failed to build, make sure that libpng-dev is installed


✖ Error: autoreconf -fiv && ./configure --disable-shared --prefix="/home/chaos/Websites/Dreamcreator108/node_modules/mozjpeg/vendor" --bindir="/home/chaos/Websites/Dreamcreator108/node_modules/mozjpeg/vendor" --libdir="/home/chaos/Websites/Dreamcreator108/node_modules/mozjpeg/vendor" && make --jobs=2 && make install --jobs=2
Command failed: autoreconf -fiv
/bin/sh: 1: autoreconf: not found

安装所需要的依赖:

apt install libpng-dev libtool automake autoconf nasm pkg-config

重新安装,问题解决。